Anyone use Amazon Flex App on Unreal Mobile?

SHBSHB Posts: 2Member

I am unable to load the app on Unreal Mobile mobile data. I can start the app on any Wifi then switch the phone over to mobile data and app works fine after that but if I close the app and restart it, it hangs again. Anyone else have similar issue with Amazon Flex or another app and/or have a fix please share. Things already tried:

Steps I have taken to troubleshoot:

  • I have tried my old carrier sim/data and it works fine without these issues with same device.

  • I have tried another AT&T device, everything works but just Amazon Flex can't initially load and if I use Wi-Fi to load the app then switch to mobile data, it works fine until I close the app and restart it.

  • I have tried my second (Wife's account) Unreal Mobile sim and get same results.

  • I have tried my AT&T device and her AT&T device, same results.

  • I have rebooted, cleared cache and dalvik, even factory reset the device in question.

  • I have cleared data and cache on Unreal Mobile app and on Amazon Flex app, even have reinstalled both apps on both devices, still same issue.

  • I have tried using the app at many different locations miles away from each other but still same results, I have tried with full signal strength/bars to make sure it isn't signal issue.

  • I have correct APN settings as provided by Unreal Mobile (unreal.com.attz), I have even deleted and recreated APN.

  • I have checked and made sure I have latest available firmware for my devices (Android 6.0).

  • I do not have VPN turned on and just to make sure, tried to turn VPN on to try with it on, but it doesn't turn on through Unreal Mobile app anyways.

The devices I am using are LG G4 H810 and LG V10 H900, other carrier sims work fine in both of these phones and I do not have this issue with that carrier and these same devices.

I suspect it is something that AT&T or Unreal Mobile are adding to the packet headers where an initial handshake between this app and Amazon servers doesn't work. Once I login the app using Wifi, the app works as it normally should.

Any tips or help to fix this issue will be appreciated. Thanks.

Sign In or Register to comment.